Back to overview
Resolved
Release 3.124.1
Aug 5, 2026 at 7:23am UTC
–
Aug 5, 2026 at 7:31am UTC
Affected services
Honey Application (Europe)
Resolved
Aug 5, 2026 at 7:31am UTC
Completed! All bees are buzzing.
Affected services
Updated
Aug 5, 2026 at 7:31am UTC
Maintenance ended
Affected services
Created
Aug 5, 2026 at 7:23am UTC
Release 3.124.1
Affected services