Back to overview
Maintenance
Release 3.90.0
Aug 26 at 08:58am CEST
–
Aug 26 at 09:53am CEST
Affected services
Honey Application (Europe)
Honey API (Europe)
Trialbee Recruitment Widget (Europe)
Resolved
Aug 26 at 09:53am CEST
Release finished. A lot of work was put into making our system perform better. Please report any issues or happy cheers to support@trialbee.com.
Affected services
Created
Aug 26 at 08:58am CEST
Release 3.90.0
Affected services